
Siemens Enterprise Communications
www.siemens-enterprise.com

Documentation
myReports, User Guide
P31003P1030U106017619
05/2012
Siemens Enterprise Communications GmbH & Co. KG.
2012

OpenScape Office V3
myReports

User Guide

A31003-P1030-U106-13-7619



Siemens Enterprise Communications
www.siemens-enterprise.com

Our Quality and Environmental Management 
Systems are implemented according to the 
requirements of the ISO9001 and ISO14001 
standards and are certified by an external certification 
company.




Copyright © Siemens Enterprise 
Communications GmbH & Co. KG 05/2012
Hofmannstr. 51, D-80200 München

Siemens Enterprise Communications GmbH & Co. KG 
is a Trademark Licensee of Siemens AG

Reference No.: A31003-P1030-U106-13-7619

The information provided in this document contains 
merely general descriptions or characteristics of 
performance which in case of actual use do not always 
apply as described or which may change as a result of 
further development of the products. An obligation to 
provide the respective characteristics shall only exist if 
expressly agreed in the terms of contract. Availability 
and technical specifications are subject to change 
without notice. 

OpenScape, OpenStage and HiPath are registered 
trademarks of Siemens Enterprise 
Communications GmbH & Co. KG. 
All other company, brand, product and service names 
are trademarks or registered trademarks of their 
respective holders. 



Contents
1  Introduction . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
1.1  myReports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
1.2  New Features  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
1.3  Types of Topics . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
1.4  Display Conventions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
1.5  User Interface Elements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

2  Installing and Starting myReports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
2.1  Prerequisites for myReports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10
2.2  How to Install myReports . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
2.3  How to Start myReports. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
2.4  How to Switch Users . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
2.5  How to Deactivate the Automatic Login . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 15
2.6  How to Uninstall myReports. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16
2.7  Automatic Updates. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

2.7.1  How to Perform Automatic Updates  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17
2.8  Upgrading to OpenScape Office V3  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

3  First Steps . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
3.1  How to Select the User Interface Language . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18
3.2  How to Test an E-mail Account for Sending Reports by E-mail  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19

4  Reports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20
4.1  Predefined Report Templates  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23
4.2  How to Display a Report Preview  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24
4.3  How to Send a Report Immediately by E-mail . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 25
4.4  How to Add a Report Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
4.5  How to Delete a Report Template . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26
4.6  How to Update Predefined Report Templates . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27
4.7  Report Designer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27

4.7.1  How to Start the Report Designer  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28
4.7.2  How to Start the Online Help of the Report Designer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

5  Schedules  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29
5.1  How to Add a Schedule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32
5.2  How to Display the Details of a Schedule  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
5.3  How to Edit a Schedule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 34
5.4  How to Delete a Schedule . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35

6  Configuration  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36
6.1  Configuration by the myReports User . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36

6.1.1  How to Change the Language of the User Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
6.1.2  How to Change the Color of the User Interface . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37
6.1.3  How to Configure an E-mail Template (Text) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38
6.1.4  How to Configure an E-mail Template (HTML). . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38
6.1.5  How to Change the Server Address  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39

6.2  Configuration by the myReports Administrator . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39
6.2.1  How to Change the Administrator Password  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42
6.2.2  How to Configure an E-mail Account to Send Reports by E-mail  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43
6.2.3  How to Configure Prefixes for External Phone Numbers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44
A31003-P1030-U106-13-7619, 05/2012
myReports, User Guide 3



Contents
6.2.4  How to Activate or Deactivate Data Protection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45
6.2.5  How to Configure the Storage Location for Exporting Scheduled Reports . . . . . . . . . . . . . . . . . . . . . . 45
6.2.6  How to Add a New Language for the User Interface and Report Templates  . . . . . . . . . . . . . . . . . . . . 46
6.2.7  How to Delete a Language for the User Interface and Report Templates  . . . . . . . . . . . . . . . . . . . . . . 48
6.2.8  How to Export the Language Texts of the User Interface and Report Templates  . . . . . . . . . . . . . . . . 49
6.2.9  How to Reset All Languages of the User Interface and Report Templates  . . . . . . . . . . . . . . . . . . . . . 50

7  Appendix. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
7.1  myReports User Roles . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51
7.2  myReports Data Relationship Model. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53

Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 54
 A31003-P1030-U106-13-7619, 05/2012
4 myReports, User Guide



Introduction
myReports
1  Introduction

This document is intended for the users of myReports and describes its 
installation, configuration and operation. 

myReports can be used with the following communication systems: 

• OpenScape Office V3 
Related Topics

1.1  myReports

myReports is an application for creating reports on Contact Center agents and 
their activities, including calls, queues, performance, GOS (Grade of Service) and 
wrap-up codes. 

myReports offers the following features: 

• More than 100 predefined report templates sorted by subject area (report 
groups) for the creation of reports 

• Schedules for the scheduled generation of reports 

• Immediate or scheduled sending of reports by e-mail 

• Scheduled export of reports 

• Output formats for report previews, sent e-mails and exported reports: Excel, 
PDF, and Word 

• Report preview to check a report to be created in the desired output format. 

• Integrated Report Designer for defining customized report templates (by the 
myReports administrator) 

Backup and Restore

When the data of the communication system is backed up and restored, the 
reports and schedules of myReports are also taken into account. 
Related Topics

1.2  New Features 

Starting with OpenScape Office V3.3, myReports provides the following new 
features. 

Report Templates 

• A targeted selection of multiple agents is now possible in selected report 
templates 

• A targeted selection of multiple queues is now possible in selected report 
templates 

• New report templates in Calls report group: 

– Incomplete Calls 

– Contact Center - Transferred Calls 
A31003-P1030-U106-13-7619, 05/2012
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Types of Topics
• New CLI report group with the following new report templates: 

– Calling Party Number One Number Statistic Details 

– Calling Party Number Summary Report Detailed 

– Calling Party Number Traffic per CLI Fragment Per Hour Daily 

– Customer ID - One Customer Number Statistic Details 

• New Fax/E-mail report group with the following new report templates: 

– Contact Center Summary - Fax/E-mail 

– E-mail - One Queue Statistic Details 

– Fax - One Queue Statistic Details 

Exporting Reports 

Scheduled reports can be stored on the communication system (OpenScape 
Office MX) or the Linux server of OpenScape Office HX (HiPath 3000) and/or any 
PC or server in the network. 

Data Protection in Reports 

• When configuring myReports, the administrator of myReports can enable 
data protection. This causes the last four digits of of the phone numbers (CLI 
column) to be replaced by **** in all reports involved. 

• If the subscriber has flagged his or her private number, mobile number, 
external number 1 and/or external number 2 as invisible, these phone 
numbers will not be displayed in all relevant reports. 

Related Topics

1.3  Types of Topics

The types of topics include concepts and operating instructions. 

Related Topics

Type of topic Contents Title

Concept Explains the "What". without a verb as in 
"Report Designer" or with 
a gerund as in Installing 
and Starting myReports. 

Operating 
instructions

Describe task-oriented application 
cases – i.e., the "How" – and assumes 
familiarity with the associated concepts.

Starts with "How to" 
followed by a verb, as in 
How to Add a Report 
Template.
 A31003-P1030-U106-13-7619, 05/2012
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Display Conventions
1.4  Display Conventions

This documentation uses a variety of methods to present different types of 
information. 

Related Topics

Purpose Appearance Sample

User Interface Elements Bold Click OK. 

Menu sequence > File > Exit 

Special emphasis Bold Do not delete Name.

Cross-reference text Italics You will find more 
information in the 
topicNetwork.

Output Monospace font, e.g., 
Courier

Command not found.

Input Monospace font, e.g., 
Courier

Enter LOCAL as the file 
name.

Key combination Monospace font, e.g., 
Courier

<Ctrl>+<Alt>+<Esc>

Work Steps and Substeps Numbered and alphabetical 
lists

• Configure the DSL 
telephony stations with 
the associated DID 
phone numbers.

– Click Add.

– Enter the name of the 
Internet telephony 
station under Internet 
Telephony Station.

Alternative Work Steps Enumeration • If you want to output 
amounts, enable the 
check box Display 
amounts instead of 
units.

• If you want to output 
units, clear the check 
box Display amounts 
instead of units.
A31003-P1030-U106-13-7619, 05/2012
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User Interface Elements
1.5  User Interface Elements

The user interface of myReports consists of the main window with different areas. 

The main window consists of the following elements: 

• Menu bar (1) with the menus 

– File 

– Administration 

– Help 
and the name of the logged in user. 
Menu items can also be invoked via the keyboard shortcuts next to each 
menu item. 

• Function menu (2) with the symbols: 

• Report Explorer (3): only in connection with Schedule Manager 
Contains all report templates in a tree structure, grouped with emphasis on 
content. 

Symbol Function

Schedule Manager 

Report Manager

My Schedules

1 

3 

2 

5 

4 
 A31003-P1030-U106-13-7619, 05/2012
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User Interface Elements
• Workspace (4): only in connection with Schedule Manager 

• Status bar (5), with information on 

– the status of the connection to the communication system 
(OpenScape Office MX) or the Linux server of OpenScape Office HX 
(HiPath 3000 3000). 

– Date and Time. 

Tooltips

Tooltips are tiny windows in which myReports displays more information on 
certain objects of the graphical user interface such as icons, for example. A tool 
tip appears when you let the mouse pointer hover over the corresponding object 
for some time. 
Related Topics

Related Topics 

• Reports

• Schedules

Symbol Function

Report Parameters

The display of the other icons depends on the selected function. 
A31003-P1030-U106-13-7619, 05/2012
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Installing and Starting myReports
Prerequisites for myReports
2  Installing and Starting myReports

This section provides you with details on the hardware and software prerequisites 
for myReports, the procedures for installing and starting myReports, and on 
updates and upgrades. 

Password

The password applies to myReports, myAgent, myAttendant, myPortal for 
Desktop, myPortal for Outlook and OpenScape Office Fax Printer as well as 
phone access to your voicemail box. 

You cannot change the password in myReports. The password can only be 
changed in myAgent, myAttendant, myPortal for Desktop and myPortal for 
Outlook or via the phone menu of the voicemail box. 

License 

The license permits the parallel installation of myReports for multiple users. Only 
one user can use myReports at any given time. 

Switching the User 

You can switch the user without exiting myReports. 

Automatic Login 

You can use the automatic login if you want to start myReports without having to 
log in via the Login window. 

NOTICE:  You should use the automatic login only if you are 
certain that no-one else has access to your Windows user 
account. Otherwise, unauthorized users could, for example, 
potentially access your voicemails and fax messages or redirect 
your station number to external toll-based destinations. 

Related Topics

2.1  Prerequisites for myReports

In order to use myReports, the client PC of the subscriber must be equipped with 
the appropriate hardware and software configurations. 

NOTICE:  Please make sure that you refer to the notes in the 
ReadMe first file, which is located in the storage directory of 
the install files. 
 A31003-P1030-U106-13-7619, 05/2012
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Prerequisites for myReports
Minimum Requirements for myReports 

• Operating system: 

– Microsoft Windows 7 

– Microsoft Windows Vista 

– Microsoft Windows XP 

NOTICE:  The used operating system always requires the latest 
version of all available updates (Service Packs and patches) as 
well as Microsoft .NET Framework 4 or later. 

• Web browser: 

– Microsoft Internet Explorer Version 7 

– Microsoft Internet Explorer Version 8 in compatibility mode 

– Microsoft Internet Explorer Version 9 

– Mozilla Firefox Version 4 or later 

• Additional Software: 

– Java 1.6.x 

– Adobe Reader 9 (for reports in PDF format) 

– Microsoft Excel (for reports in Excel format) 

– Microsoft Word (for reports in Word format) 

• Hardware: 

– 2 GHz CPU

– 1 GB RAM for Microsoft Windows XP 
2 GB RAM for Microsoft Windows 7 and Microsoft Windows Vista 

– 100 Mbps LAN (1 Gbps LAN recommended)

– XGA (1024x768) screen resolution

Multi-user PCs

Under Microsoft Windows 7, Microsoft Windows Vista and Microsoft Windows XP 
with multi-user PCs, every local user can use myReports with his or her own 
custom settings, provided the first local user has installed the client with local 
administration rights. Only the first local user with local administration rights can 
perform updates via the AutoUpdate. 

Microsoft Terminal Server, Citrix XenApp Server 

myReports can be used in terminal server environments under the following 
conditions: A project-specific release is required for this. 

INFO:  Terminal Server environments, including hosted services 
and virtual environments, are the responsibility of the customer. 

• Software: 

– Microsoft Windows 2008 R2 Server with Citrix XenApp 6.0 Server 
(Desktop Mode) 
A31003-P1030-U106-13-7619, 05/2012
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Prerequisites for myReports
– Microsoft Windows 2008 R2 Server with Citrix XenApp 5.0 Server 
(Desktop Mode) 

– Microsoft Windows 2008 R2 Server as Microsoft Terminal Server 

– Microsoft Windows 2008 R2 Server as Microsoft Terminal Server 

– Microsoft Windows 2003 Server as Microsoft Terminal Server 

NOTICE:  The used software always requires the latest version of 
all available updates (Service Packs and patches) as well as 
Microsoft .NET Framework 4 or later. 

• Hardware: 
The number of installable clients depends on the server performance and on 
the amount of available memory. If the server is also being used for other 
applications, their memory requirements must also be taken into account. 
More information on the configuration of Citrix XenApp Server can be found 
under: 
http://wiki.siemens-enterprise.com/wiki/
OpenScape_Office. 

Installation Files

The following options are available for providing installation files to users: 

• The administrator downloads the installation files from the Download Center 
and provides them to users via a network drive, for example. 

• You can directly access the installation files by connecting to the network drive 
with: 
\\<IP address of the communication system>\applications 
User: hoome, Password: hoomesw 
The installation files are located in the install-myReports folder. 

Please refer to the notes in the ReadMe first file, which is located in the 
storage directory of the install files. 

NOTICE:  The automatic distribution of the MSI file via a 
deployment service with Microsoft Windows Server is not 
supported. 

Related Topics

Related Topics 

• How to Install myReports
 A31003-P1030-U106-13-7619, 05/2012
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Installing and Starting myReports
How to Install myReports
2.2  How to Install myReports

Prerequisites

• Your PC meets the requirements described under Prerequisites for 
myReports . 

• Your Windows user account has local administration rights for the installation. 

• The installation file is available to you. 

INFO:  Please make sure that you refer to the notes in the 
ReadMe first file. 

Step by Step

1) Perform the installation. 

2) If the User Account Control window appears with the message An 
unidentified program wants access to your computer, click 
Allow. 

3) Follow the instructions of the Installation program. 

Next steps

Activate the license for myReports. 
Related Topics

Related Topics 

• Prerequisites for myReports

• How to Start myReports

• How to Uninstall myReports

2.3  How to Start myReports

Prerequisites

• You are an agent of the Contact Center with the authorization level (class of 
service) of a supervisor or an administrator. 

• myReports is installed on your PC. 

• The license for myReports has been activated. 

• myReports was not started by any other user. 
A31003-P1030-U106-13-7619, 05/2012
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How to Start myReports
Step by Step

1) Click Start > Program Files > Communication Clients > myReports. You 
will then be presented with the login screen. 

2) Enter your user name in the Login Name field. This is usually your station 
number. If you have any questions, please contact the administrator of your 
communication system. 

3) Enter your password, which must consist of only digits, in the Password field. 
The default password when logging in for the first time is 1234. If you have 
any questions, please contact the administrator of your communication 
system. 

NOTICE:  If the wrong password is entered five times, your 
access to all Contact Center Clients and UC clients will be locked. 
Unlocking is only possible by the administrator of your 
communication system. 

4) If you want to use myReports with an automatic login in the future, enable the 
Save Password check box. The Login window will then no longer be 
displayed. You can change this option at any time; see How to Deactivate the 
Automatic Login . 

NOTICE:  You should use the automatic login only if you are 
certain that no-one else has access to your Windows user 
account. Otherwise, unauthorized users could, for example, 
potentially access your voicemails and fax messages or redirect 
your station number to external toll-based destinations. 

5) Select one of the following options for the entry in the Server address field: 

• If you are using myReports at the OpenScape Office MX communication 
system, enter the IP address of your communication system in the Server 
Address field (if this is not already displayed). 

• If you are using myReports at the HiPath 3000 communication system, 
enter the IP address of the Linux server of OpenScape Office HX in the 
Server Address field (if this is not already displayed). 

6) Click Login. 
Related Topics

Related Topics 

• How to Install myReports

• How to Switch Users

• How to Deactivate the Automatic Login
 A31003-P1030-U106-13-7619, 05/2012
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How to Switch Users
2.4  How to Switch Users

Prerequisites

• myReports was started. 

Step by Step

1) Click File > Logout The Login window appears. 

2) Log in (see How to Start myReports , as of step 2). 
Related Topics

Related Topics 

• How to Start myReports

2.5  How to Deactivate the Automatic Login

Prerequisites

• myReports was started. 

Step by Step

1) Click File > Logout The Login window appears. 

2) Clear the Save Password check box. 

3) Log in (see How to Start myReports , as of step 2). 
Related Topics

Related Topics 

• How to Start myReports
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How to Uninstall myReports
2.6  How to Uninstall myReports

Step by Step

1) Close myReports. 

NOTICE:  Please make sure that you refer to the notes in the 
ReadMe first file. 

2) Select one of the following options: 

• Windows XP: Double-click in the Control Panel on Software. 

Click on the myReports item and then on Remove. 

• Windows Vista: Double-click in the Control Panel on Programs and 
Features. 

Click Uninstall in the context menu of myReports entry. 

• Windows 7: Click in the Control Panel on Programs. 

Click on Programs and Features. 

Click Uninstall in the context menu of myReports entry. 

3) Follow the instructions of the uninstallation program. 
Related Topics

Related Topics 

• How to Install myReports

2.7  Automatic Updates

Automatic updates ensure that myReports is always kept up-to-date with the 
latest version. 

If myReports determines that a newer version is available on the communication 
system (OpenScape Office MX) or the Linux server of OpenScape Office HX 
(HiPath 3000), a corresponding message is displayed. The automatic update is 
performed on exiting myReports. 
Related Topics
 A31003-P1030-U106-13-7619, 05/2012
16 myReports, User Guide



Installing and Starting myReports
Upgrading to OpenScape Office V3
2.7.1  How to Perform Automatic Updates 

Prerequisites

• Your PC meets the requirements described under Prerequisites for 
myReports . 

• You have received a message such as: OpenScape Office client 
update available. Please wait while the update is done. 
Please close the following programs to continue the 
update: [...]. 

Step by Step

› Close the named programs. 

Next steps

Restart myReports after the automatic update. 
Related Topics

2.8  Upgrading to OpenScape Office V3 

An upgrade to OpenScape Office V3 requires a different procedure to the usual 
updates. 

INFO:  Please make sure that you refer to the notes in the 
ReadMe first file. 

All clients of OpenScape Office V2 must be uninstalled from the client PC. The 
latest version of myReports can then be installed. The procedure depends, 
among other things, on the operating system. 

Your personal settings and data are retained on upgrading to OpenScape Office 
V3. 

For more information on upgrading to OpenScape Office V3, contact the 
administrator of your communication system. 

Custom Configuration

Your custom configuration is retained for the most part, except for the following 
area under Administration > myReports Settings. 

After the upgrade, you should check the configuration in this area and edit them 
if required. 
Related Topics
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How to Select the User Interface Language
3  First Steps

The First Steps describe the recommended actions to be taken right at the 
beginning. 

Select the language 

Select the language of the user interface of myReports. 

Configuring an E-mail Account to Send Reports by E-mail 

Check if an e-main account was configured for sending reports by e-mail. 

INFO:  When setting up the communication system 
(OpenScape Office MX) or the Linux server of 
OpenScape Office HX (HiPath 3000), an e-mail account via 
which the communication system or Linux server can send e-
mails is configured. 

The sending of reports by e-mail using myReports occurs through 
either the e-mail account configured in the communication system 
or in the Linux server of OpenScape Office HX or the e-mail 
account configured in myReports by the myReports administrator. 

Related Topics

3.1  How to Select the User Interface Language 

Step by Step

1) Click on Administration > myReports Settings. 

2) Select the desired language in the Language drop-down list. 

3) Click Save. 

4) Click File > Logout The Login window appears. 

5) Log in (see How to Start myReports , as of step 2). 
Related Topics
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How to Test an E-mail Account for Sending Reports by E-mail
3.2  How to Test an E-mail Account for Sending Reports by E-mail 

Prerequisites

• You know the data of the e-mail account that can be used to send reports. 

Step by Step

1) Click Administration > E-mail Setup. The data of the configured e-mail 
account is displayed. 

2) Check whether the data is complete and correct. 

Next steps

Contact the myReports administrator if the displayed details are incomplete or 
invalid. 
Related Topics
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4  Reports

As a myReports user, you can create reports on Contact Center agents and their 
activities, including calls, queues, performance, GOS (Grade of Service) and 
wrap-up codes. 

Reports can be created from approx. 100 predefined report templates, which are 
sorted by subject area (report groups). 

INFO:  It is advisable to not create reports with more than 100 
pages. If required, the reporting period for the report should be 
restricted accordingly. 

As a myReports administrator, you can define your own report templates with the 
integrated Report Designer. 

Call History 

Reports based on the call history stored in the communication system. The 
maximum retention period for the call history is 365 days (default setting). The 
administrator of your communication system can set the retention period for the 
call history on a system-wide basis. 

Example: The retention period was set to 100 days. This means that only data 
that is up to 100 days old can be used for the preparation of reports. 

Language 

Reports are created in the language of the user interface of myReports. 

Report Parameters 

Before creating a report, you will need to set report parameters to define the 
period (date, time) and entities (agents, queues, etc.) to be measured. 

The following report parameters are available: 

• From Date 
Date for the start of the reporting period 

• To Date 
Date for the end of the reporting period 

• From Time 
Time for the start of the reporting period 

• To Time 
Time for the end of the reporting period 

• Queue Name 
Relevant queue for the report 

• Queues 
Relevant queues for the report 

• Agent 
Relevant agent for the report 
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• Agents 
Relevant agents for the report 

• User 
Relevant internal subscribers for the report 

• CLI 
Relevant phone number of an external subscriber (customers) for the report 

• CLI Fragment 
Relevant phone number portion of external subscribers (customers) for the 
report 

• Customer ID 
Relevant Customer ID for the report 

• Wrap up Description
Relevant wrapup code for the report 

• Wrap up Group
Relevant wrapup group for the report 

• Business Hours Only
This option takes only the business hours configured in OpenScape Office 
into account. 

• Daily Report
This option arranges the results of report on a daily basis. 

Output Formats 

You can choose between the following output formats for the report preview and 
when sending reports by instant e-mail: 

• Excel 

• PDF 

• Word 

Note that a graphical representation of the report results is not possible in the 
Excel output formats. 

Data Protection 

When configuring myReports, the administrator of myReports can enable data 
protection. This causes the last four digits of of the phone numbers (CLI column) 
to be replaced by **** in all reports involved. 

If the subscriber has flagged his or her private number, mobile number, external 
number 1 and/or external number 2 as invisible, these phone numbers will not be 
displayed in all relevant reports. 

Report Manager 

The Report Manager is used to manage the report templates. It shows a list of 
all report templates with the following details: 

• ID

• Report Name

• Report Group
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You can sort the report templates by any column in ascending or descending 
alphanumeric order. In addition, the Report Manager includes a drop-down list 
for selecting the displayed report group(s), a display indicating the number of 
report templates, and the following symbols: 

You can also create additional report groups and store them in the Report 
Manager. 

Report Preview 

If desired, you can create a report preview in one of the output formats and either 
save it or open it immediately with the appropriate application. 

Immediate Delivery by E-mail 

You can send a report as an e-mail attachment to any desired recipient at any 
time. The subject of the e-mail always begins with your last name and your e-mail 
address that is configured in the communication system. You can also add 
additional text to the Subject line if required. 

Report Designer 

As a myReports administrator, you can customize the report templates to your 
individual needs via the integrated Report Designer if required and store them as 
new report templates in the Report Manager. 

Default Reports 

The predefined report templates can be updated by a myReports administrator. 

NOTICE:  Note that all schedules are deleted on updating the 
predefined report templates. 

Related Topics

Related Topics 

• User Interface Elements

• Schedules

Symbol Function

Refresh

Delete Report

Select File

Add Report
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Predefined Report Templates
4.1  Predefined Report Templates

myReports provides about 100 predefined report templates for creating reports. 

These templates are classified by subject area and assigned to the following 
report groups: 

• Agent Activity

• Agents

• CLI 

• Call History

• Calls

• Fax / E-Mail

• Other

• Performance

• Queues

• User Presence Status

• Wrap-up Codes

INFO:  The predefined report templates cannot be edited by a 
myReports user. 

A myReports administrator can, however, customize the 
predefined report templates via the integrated Report Designer 
and store them as new report templates in the Report Manager. 

Updating Predefined Report Templates 

Following an update to the myReports application software, some new predefined 
report templates may be available. As a myReports administrator, you can update 
the predefined report templates and thus make the new templates available to all 
myReports users. 

NOTICE:  On updating the predefined reports, all schedules are 
deleted. 

Related Topics

Related Topics 

• How to Update Predefined Report Templates
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How to Display a Report Preview
4.2  How to Display a Report Preview

Prerequisites

• The prefixes for external phone numbers have been configured. 

Step by Step

1) Click Schedule Manager. 

2) Click in the Report Explorer on the desired report template in the appropriate 
report group. 

3) Use the report parameters to define the time period and entities to be 
measured. 

INFO:  The report parameters depend on the selected report 
template. More information on the various report parameters can 
be found under Reports . 

4) Click OK followed by OK. 

5) Select one of the following options in the Format drop-down list: 

• PDF

• XLS (Excel)

• DOC (Word)

6) Click the Preview Report icon. The report is then displayed in the selected 
output format. 

Related Topics
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How to Send a Report Immediately by E-mail
4.3  How to Send a Report Immediately by E-mail

Prerequisites

• An e-mail account to send reports by e-mail has been configured. 

• Your e-mail address has been configured in the communication system. 

• The prefixes for external phone numbers have been configured. 

Step by Step

1) Click Schedule Manager. 

2) Click in the Report Explorer on the desired report template in the appropriate 
report group. 

3) Use the report parameters to define the time period and entities to be 
measured. 

INFO:  The report parameters depend on the selected report 
template. More information on the various report parameters can 
be found under Reports . 

4) Click OK followed by OK. 

5) Select one of the following options in the Format drop-down list: 

• PDF

• XLS (Excel)

• DOC (Word)

6) Click the Sending attached report file icon. 

7) Enter the e-mail address of the desired recipient in the To field. 

8) If desired, enter an additional text for the Subject line of the e-mail in the 
Subject field. 

INFO:  The subject of an e-mail always begins with your last name 
and your e-mail address that is configured in the communication 
system. 

9) Enter the message text for the e-mail in the Message : field. 

10) Click Send followed by OK. 
Related Topics

Related Topics 

• How to Configure an E-mail Account to Send Reports by E-mail

• How to Configure Prefixes for External Phone Numbers
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How to Add a Report Template
4.4  How to Add a Report Template

Prerequisites

• A new report template (file of the type .rptdesign) is available. 

Step by Step

1) Click Report Manager. 

2) Click the Select File icon. 

3) Choose the desired file in the file selection dialog box and click Open. 

4) Select one of the following options: 

• If you want to save the report template in an existing report group, select 
the desired report group from the drop-down list. 

• If you want to save the report template in a new report group, select the 
item New Report Group in the drop-down list. Replace the entry New 
Report Group in the drop-down list with the name for the new report 
group. 

5) Click the Delete icon, followed by OK. 
Related Topics

4.5  How to Delete a Report Template

Prerequisites

• You are logged on to myReports with the user name under which the report 
template was added. 

• The report template is not included in any schedule. 

Step by Step

1) Click Report Manager. 

2) Select the desired report group from the drop-down list for the report groups. 

3) Click in the list of report templates on the desired report template. 

4) Click the Delete report icon, followed by OK. 

5) Click OK. 
Related Topics
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How to Update Predefined Report Templates
4.6  How to Update Predefined Report Templates

Prerequisites

• You are logged into myReports as a myReports administrator. 

Step by Step

1) Click on Administration > Default Reports. 

NOTICE:  On updating the predefined reports, all schedules are 
deleted. 

2) To confirm, click OK. 

Next steps

myReports exits and restarts automatically. 
Related Topics

Related Topics 

• Predefined Report Templates

4.7  Report Designer 

As a myReports administrator, you can define your own report templates with the 
Report Designer integrated in myReports. 

The Report Designer is a separately started Open Source application (called the 
BIRT RCP Designer) for the professional creation of report templates. BIRT is an 
acronym for Business Intelligence and Reporting Tools. 

myReports supports the BIRT RCP Designer through 

• the predefined database connection, 

• the integration of report templates used in myReports. 

• a data transfer program for integrating newly created report templates in the 
Report Manager. 

In order to use the Report Designer successfully, familiarity with the application 
itself as well as database structures, SQL and Java are required. 

Information on using the Report Designer can be found in the associated online 
help. 
Related Topics

Related Topics 

• myReports Data Relationship Model
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Report Designer
4.7.1  How to Start the Report Designer 

Prerequisites

• You are logged into myReports as a myReports administrator. 

Step by Step

› Click Administration > Report Designer. 
Related Topics

4.7.2  How to Start the Online Help of the Report Designer

Prerequisites

• You have started the Report Designer. 

Step by Step

› Click in the Report Designer on Help > Help Contents. 

INFO:  To familiarize yourself with the Report Designer, it is 
advisable to read the section BIRT Report Developer Guide > 
Field Guide to BIRT > Learning the Basics in the help. 

Related Topics
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5  Schedules

A schedule defines the time-controlled creation of a specific report. 

Schedule Name 

A schedule name consists of the name of the report in that schedule, followed by 
the schedule ID. 

Report Parameters 

Before creating a report, you will need to set report parameters to define the 
period (date, time) and entities (agents, queues, etc.) to be measured. 

Time of Execution

You can configure the following execution times for the schedule: 

• Start Date
The execution of the schedule is initiated on the start date. 

• End Date
The execution of the schedule is repeated at the configured recurrence 
intervals until the end date is reached. 

• Time
The schedule is run for the first time at the time specified here. 

If multiple schedules are to be run at the same time, the corresponding reports 
are generated at intervals of one minute each for performance reasons. This has 
no effect on the contents of the reports 

Output Method 

The following options are available for the output of a scheduled report: 

• Delivery by E-mail 
Scheduled reports can be sent to your e-mail address or the e-mail addresses 
of other recipients. This requires an e-mail account to have been configured 
for sending reports. 
The e-mail address of a recipient can be entered manually or selected from a 
drop-down list. The drop-down list contains all the internal users of your 
communication system for whom e-mail addresses have been configured. 

• Exporting Reports 
Scheduled reports can be stored on the communication system (OpenScape 
Office MX) or the Linux server of OpenScape Office HX (HiPath 3000) and/or 
any PC or server in the network. 
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Recurrence

You can configure the following types of recurrence for the execution of a 
schedule based on the time specified for the first execution: 

• Hourly

• Daily

• Every n days

• Weekly

• Every n weeks

• Monthly

• Every n months

• Yearly

Schedule Manager 

The Schedule Manager is used to create schedules and contains the following 
symbols: 

Symbol Function

Delete schedule

Edit schedule

Save Schedule

Preview report

Sending attached report file
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My Schedules 

My Schedules can be used to manage your own schedules and to display a list 
with the following details: 

• ID

• Schedule Name
You can only view your own schedules. 

• Start Schedule
Start of the time period in which the schedule is executed. 

• End Schedule
End of the time period in which the schedule is executed. 

• Recurrence
Type and interval of the recurrence. 

You can sort the schedules by any column in ascending or descending 
alphanumeric order. In addition, My Schedules contains the symbols below: 

Related Topics

Related Topics 

• User Interface Elements

• Reports

Symbol Function

Delete schedule

Edit schedule

View Details

Shows the following additional information: 

• Time for the first execution

• Output format

• If applicable: e-mail address of the recipient

• If applicable: further details on the recurrence
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How to Add a Schedule
5.1  How to Add a Schedule

Prerequisites

• An e-mail account to send reports by e-mail has been configured. 

• An e-mail template has been configured. 

• The data for exporting reports has been configured. 

• The prefixes for external phone numbers have been configured. 

Step by Step

1) Click Schedule Manager. 

2) Click in the Report Explorer on the desired report template in the appropriate 
report group. 

3) Use the report parameters to define the time period and entities to be 
measured. 

INFO:  The report parameters depend on the selected report 
template. More information on the various report parameters can 
be found under Reports . 

4) Click OK followed by OK. 

5) Select the item New Schedule in the Schedules for selected report drop-
down list. 

6) Enter the start date for the execution of the schedule in the Start Schedule 
field or click the adjacent calendar icon and select the desired start date in the 
calendar. 

7) Enter the end date for the execution of the schedule in the End Schedule field 
or click the adjacent calendar icon and select the desired end date in the 
calendar. 

8) Select the time for the execution of the schedule in the Run this scheduled 
task at list box. 

9) Select one of the following options in the Format drop-down list: 

• PDF

• XLS (Excel)

• DOC (Word)

10) Select the Recurrence check box. 
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11) Select one of the following options for the recurrence interval as well as any 
other details that may be required: 

• Hourly Recurrence

• Daily Recurrence

• Weekly Recurrence

• Monthly Recurrence

• Yearly Recurrence

12) Select one of the following options for the output method: 

• If you want to export the reports, enable the option Export Report. 

• If you want to send the reports by e-mail, proceed as follows: 

Enable the option Send the report to the user's email address Click on 
the magnifying glass icon to define the e-mail address(es) to which the 
reports are to be sent. The Email recipients window is displayed. You 
have the following options: 

Click OK. 

13) Click the Save Schedule icon. The data of the new schedule is then 
displayed. 

14) Click Save. 
Related Topics

Related Topics 

• How to Configure an E-mail Account to Send Reports by E-mail

• How to Configure an E-mail Template (Text)

• How to Configure an E-mail Template (HTML)

• How to Configure Prefixes for External Phone Numbers

– If you want to send the reports to your e-mail address configured in the 
communication system, select the check box next to your name. 

– If you want to send the reports to an internal subscriber of your 
communications system, select the desired subscriber in the drop-down list 
and click on the Plus symbol to transfer the entry to the list of e-mail 
recipients. 

Repeat the process if you want to send the reports to other internal 
subscribers. 

– If you want to enter the e-mail address of a recipient manually, enter it into 
the input field. Click on the Plus symbol to transfer the entry to the list of e-
mail recipients. 

Repeat the process if you want to enter further e-mail addresses manually. 
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5.2  How to Display the Details of a Schedule

Step by Step

1) Click My Schedules. 

2) Select the appropriate report group or the item (All Reports) in the drop-down 
list. 

3) Click on the desired schedule. 

4) Click the View Details icon. 

5) Click OK. 
Related Topics

5.3  How to Edit a Schedule

Step by Step

1) Click My Schedules. 

2) Select the appropriate report group or the item (All Reports) in the drop-down 
list. 

3) Click on the desired schedule. 

4) Click the Edit Schedule icon. 

5) If you want to change the report parameters, click on the Report Parameters 
icon. Edit the desired report parameters. 

INFO:  The report parameters depend on the selected report 
template. More information on the various report parameters can 
be found under Reports . 

Click OK followed by OK. 

6) If you want to change the start date, enter the start date for the execution of 
the schedule in the format MM/DD/YYYY in the Start Schedule field or click 
the adjacent calendar icon and select the desired start date in the calendar. 

7) If you want to change the end date, enter the end date for the execution of the 
schedule in the format MM/DD/YYYY in the End Schedule field or click the 
adjacent calendar icon and select the desired end date in the calendar. 

8) If you want to change the execution time of the schedule, select the desired 
execution time for the schedule in the Run this scheduled task at list box.

9) If you want to change the output format, select one of the following options in 
the Format drop-down list: 

• PDF

• XLS (Excel)

• DOC (Word)
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10) If you want to change the recurrence interval, select one of the following 
options for the recurrence interval as well as any other details that may be 
required: 

• Hourly Recurrence

• Daily Recurrence 

• Weekly Recurrence

• Monthly Recurrence

• Yearly Recurrence

11) If you want to change the output method, select one of the following options: 

• If you want to export the reports, enable the option Export Report. 

• If you want to send the reports by e-mail, proceed as follows: 

Enable the option Send the report to the user's email address Click on 
the magnifying glass icon to define the e-mail address(es) to which the 
reports are to be sent. The Email recipients window is displayed. You 
have the following options: 

Click OK. 

12) Click the Save Schedule icon. The data of the edited schedule is then 
displayed.

13) Click Save. 
Related Topics

5.4  How to Delete a Schedule

Step by Step

1) Click My Schedules. 

2) Select the appropriate report group or the item (All Reports) in the drop-down 
list. 

3) Click on the schedule to be deleted. 

4) Click the Delete Schedule icon, followed by OK. 

– If you want to send the reports to your e-mail address configured in the 
communication system, select the check box next to your name. 

– If you want to send the reports to an internal subscriber of your 
communications system, select the desired subscriber in the drop-down list 
and click on the Plus symbol to transfer the entry to the list of e-mail 
recipients. 

Repeat the process if you want to send the reports to other internal 
subscribers. 

– If you want to enter the e-mail address of a recipient manually, enter it into 
the input field. Click on the Plus symbol to transfer the entry to the list of e-
mail recipients. 

Repeat the process if you want to enter further e-mail addresses manually. 
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6  Configuration

You can configure myReports in accordance with your requirements. Note that 
some functions can be performed only by the myReports administrator. 

Related Topics

6.1  Configuration by the myReports User 

As a myReports user, you can customize myReports to suit your requirements via 
the following settings: 

Language of the User Interface 

Select the language of the user interface. 

Color of the user interface 

Select the color of the user interface. 

E-mail Template 

INFO:  The administrator password must be entered to configure 
the e-mail template 

In the e-mail template you can configure the Subject and the message text for all 
e-mails with which reports are sent by myReports. The following formats can be 
used for the e-mail template: 

• Text 

• HTML 

The following placeholders can be used in an e-mail template with the text format: 

The following English e-mail template in text format is available by default: 

Placeholder Meaning

{1} Report Name 

{2} Sent By 

Subject: Business report – {1} 

Message: Dear recipient(s), 

This is the scheduled report: {1}. 

Regards 

{2} 
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server address 

You can change the server address (IP address). 

NOTICE:  Do not change the server address unless you are 
instructed to do so by the administrator of your communication 
system. You cannot use myReports with an invalid server 
address. 

Related Topics

6.1.1  How to Change the Language of the User Interface 

Step by Step

1) Click on Administration > myReports Settings. 

2) Select the desired language in the Language drop-down list. 

3) Click Save. 

4) Click File > Logout The Login window appears. 

5) Log in (see How to Start myReports , as of step 2). 
Related Topics

6.1.2  How to Change the Color of the User Interface

Step by Step

1) Click on Administration > myReports Settings. 

2) Enable the radio button of the desired design. 

3) Click Save. 

4) Click File > Logout The Login window appears. 

5) Log in (see How to Start myReports , as of step 2). 
Related Topics
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6.1.3  How to Configure an E-mail Template (Text)

Prerequisites

• You know the administrator password. 

Step by Step

1) Click Administration > E-mail template. 

2) Enter the administrator password and click OK. 

INFO:  The default administrator password is reports. 

3) Enter the desired text in the Subject field. 

4) Enter the desired text in the Message field. 

5) Click on Save and then on Cancel. 
Related Topics

Related Topics 

• How to Add a Schedule

6.1.4  How to Configure an E-mail Template (HTML)

Prerequisites

• An appropriate HTML file (*.htm or *.html) is available. 

• You know the administrator password. 

Step by Step

1) Click Administration > E-mail template. 

2) Enter the administrator password and click OK. 

INFO:  The default administrator password is reports. 

3) Click the Browse HTML formatted message icon. 

4) Choose the desired file in the file selection dialog box and click Open. 

5) Click on Save and then on Cancel. 
Related Topics

Related Topics 

• How to Add a Schedule
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6.1.5  How to Change the Server Address 

Prerequisites

• myReports was started. 

• A new server address (IP address) is available. 

NOTICE:  Do not change the server address unless you are 
instructed to do so by the administrator of your communication 
system. You cannot use myReports with an invalid server 
address. 

Step by Step

1) Click File > Logout The Login window appears. 

2) Enter your user name in the Login Name field if it is not shown. 

3) Enter your password in the Password field if it is not shown. 

4) If you want to use myReports with an automatic login in the future, enable the 
Save Password check box. The Login window will then no longer be 
displayed. You can change this option at any time; see How to Deactivate the 
Automatic Login . 

NOTICE:  You should use the automatic login only if you are 
certain that no-one else has access to your Windows user 
account. Otherwise, unauthorized users could, for example, 
potentially access your voicemails and fax messages or redirect 
your station number to external toll-based destinations. 

5) Enter the new IP address in the Server IP field. 

6) Click Login. 
Related Topics

6.2  Configuration by the myReports Administrator 

As a myReports administrator, you can configure myReports via the following 
settings: 

Administrator Password 

Changing the password for the myReports administrator. The default login name 
is Administrator, and the default password is reports. 

INFO:  The administrator of your communication system can reset 
the administrator password with OpenScape Office Assistant. 
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Configuring an e-mail account to send reports by e-mail 

In order to enable myReports to send reports by e-mail, access to an already 
existing e-mail account must be configured. This configuration (for sending e-
mails) usually occurs 

• when setting up the communication system, if you are using myReports at the 
OpenScape Office MX communication system. 

• when setting up the Linux server of OpenScape Office HX, if you are using 
myReports at the HiPath 3000 communication system 

The sending of reports by e-mail via myReports occurs through the e-mail 
account configured in the communication system or the Linux server of 
OpenScape Office HX. 

Configure access to an existing e-mail account in myReports if 

• no e-mail account for sending e-mails was configured during the setup 

• the e-mail account to be used for sending reports via myReports is not the 
same as the one configured in the communication system or the Linux server 
of OpenScape Office HX. 

Prefixes for External Phone Numbers 

In order to enable myReports to handle different types of connections (for 
example, international calls or calls from mobile phones), you must configure the 
appropriate prefixes for external call numbers. 

The following prefixes for external phone numbers can be configured: 

Data Protection 

You can enable Data Protection. This causes the last four digits of of the phone 
numbers (CLI column) to be replaced by **** in all reports involved. This also 
applies to reports that are created with myAgent. 

Type Examples Considered in the following predefined 
report templates (examples)

International 00  Incoming Calls (International)-Per User 

Outgoing Calls (International)-Per User 

Mobile/Cell 14;15;16 Incoming Calls (Mobile-Cell)-Per User 

Outgoing Calls (Mobile-Cell)-Per User 

Free Call 0800 Incoming Calls (Free-Calls) - Per User 

Outgoing Calls (Free-Calls)-Per User 

Pay Call 0900;0901 Outgoing Calls (Pay-Calls)-Per User 

Call to special 
phone numbers 

01;123 Incoming Calls (Specific Calls)-Per User 

Outgoing Calls (Specific Calls)-Per User 
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Exporting Reports 

You can configure the storage location for exporting scheduled reports. 

Scheduled reports can be stored on the communication system (OpenScape 
Office MX) or the Linux server of OpenScape Office HX (HiPath 3000) and/or any 
PC or server in the network. 

Languages 

INFO:  In order to configure the languages, you will need to enter 
a special password. 

By default, several different languages are available for the user interface and 
report templates of myReports. To customize myReports for your specific 
requirements, you can: 

• Add languages for the user interface and report templates. You can do this in 
the following ways: 

– Import texts of the new language via a CSV file 
The texts of the new language must be available as a CSV file in the 
format shown in the following example. Note that only one language can 
be imported at a time, and that the texts of this language must always be 
in the third column, next to the English language. In the following 
example, the language Svenska (Swedish) can be imported. 

Due to the import, the language table is extended by one column. 

– Translate texts for the new language using Google Translator 
The language table is extended by one column and populated with 
suggested translations for the new language from Google Translator. 
These suggested translations are based on the standard texts of the 
English user interface and report templates. 
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– Enter texts for the new language manually 
The language table is extended by an empty column, and you can enter 
the texts for the new language in the empty cells. 

You can edit the text in any cell of the language table by simply double-clicking 
on that cell. 
By selecting Edit > Find and Replace, you can also find any term in the 
language table and replace it with some other term. 

• Delete languages of the user interface and report templates. 
If you do not want a particular language of the UI to be made available to the 
myReports users, you can simply delete that language. 

• Save the language texts of the user interface and report templates in a CSV 
file. 
You can save the current language texts of all languages in a CSV file. 

Default Languages 

INFO:  In order to reset the languages (Default Language 
Setup), you will need to enter a special password. 

You can reset (reinitialize) the languages of the user interface and report 
templates to repair or restore a missing language, for example. 

A reset results in a restart of myReports. Following the restart, all the default 
languages will available again to all the myReports users. 
Related Topics

6.2.1  How to Change the Administrator Password

Prerequisites

• You are logged into myReports as a myReports administrator. 

Step by Step

1) Click Administration > Management. 

2) Enter the current administrator password in the Administrator Password 
field. 

3) Enter the new administrator password in the Administrator Password and 
Re-enter Password fields. 

4) Click Save. 
Related Topics
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6.2.2  How to Configure an E-mail Account to Send Reports by E-mail 

Prerequisites

INFO:  The configuration of an e-mail account to send reports by 
e-mail is only required in the following cases: 

No e-mail account was configured when setting up the 
communication system (OpenScape Office MX) or the Linux 
server of OpenScape Office HX (HiPath 3000). 

The e-mail account to be used for sending reports via myReports 
is not the same as the one configured in the communication 
system or the Linux server of OpenScape Office HX.

• You are logged into myReports as a myReports administrator. 

• You know the login data of an e-mail account that can be used by myReports 
to send reports by e-mail. 

Step by Step

1) Click Administration > E-mail Setup. 

2) Enter the server name or the IP address of the E-mail server in the E-mail 
Host field. 

3) Enter the user name of e-mail account in the E-Mail User field. 

4) Enter the password of the e-mail account in the E-mail Password field. 

5) In the field E-mail From, enter the e-mail address that is to be displayed as 
the sender. 

6) In the field E-Mail Reply To, enter the e-mail address that is to be displayed 
as the Reply To address. 

7) Click Edit. 

8) Enter the administrator password and click OK. 

9) Click Save. 
Related Topics

Related Topics 

• How to Send a Report Immediately by E-mail

• How to Add a Schedule
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6.2.3  How to Configure Prefixes for External Phone Numbers

Prerequisites

• You are logged into myReports as a myReports administrator. 

Step by Step

1) Click Administration > Phone Numbers. 

2) Enter the prefix or prefixes for international numbers in the International field. 

INFO:  Multiple prefixes can be entered in one field by separating 
the entries with ",", ";", "-", ".", "_" or "|". 

After the phone number prefixes have been saved, they are 
displayed with a ";" as the separator, regardless of which 
separator you entered. 

3) Enter the prefix or prefixes for national mobile numbers in the Mobile field. 

4) Enter the prefix or prefixes for toll free numbers in the Free Call field. 

5) Enter the prefix or prefixes for toll numbers in the Pay Call field. 

6) Enter the prefix or prefixes for special phone numbers in the Specific Call 
field. 

7) Click Save. 
Related Topics

Related Topics 

• How to Send a Report Immediately by E-mail

• How to Add a Schedule
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6.2.4  How to Activate or Deactivate Data Protection 

Prerequisites

• You are logged into myReports as a myReports administrator. 

Step by Step

1) Click on Administration > Data Protection. 

2) Select one of the following options: 

• If you want to enable data protection, select the CLI Fragmentation 
check box. 

In all reports involved, the last four digits of of the phone numbers (CLI 
column) are replaced by ****. 

• If you want to disable data protection, clear the CLI Fragmentation check 
box. 

In all reports involved, the last four digits of of the phone numbers (CLI 
column) are displayed fully. 

3) Click Save. 
Related Topics

6.2.5  How to Configure the Storage Location for Exporting Scheduled 
Reports 

Prerequisites

• You are logged into myReports as a myReports administrator. 

Step by Step

1) Click on Administration > Export Report. 

2) If you want scheduled reports to be stored on the communication system 
(OpenScape Office MX) or the Linux server of OpenScape Office HX (HiPath 
3000), select the check box Enable export. 

a) In the field System Directory enter the storage path where the scheduled 
reports are to be stored. 

The default storage path is /var/reports. 

3) If scheduled reports are to be stored on a PC or server in the network, select 
the check box Enable Remote Export. 

a) In the field Remote Host, enter the IP address of the network PC or 
server where the scheduled reports are to be stored. 

b) In the field Remote Port, enter the port of the network PC or server that 
is to be used for the export. 

c) Enter the user name for accessing the PC or server on the network in the 
User Name field 
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d) Enter the password for accessing the PC or server on the network in the 
Password field. 

e) In the field Remote Directory enter the storage path where the scheduled 
reports are to be stored. 

f) Select one of the following protocols for the export: 

NOTICE:  To enable the remote export, the PC or server in the 
network must also support the protocol selected here. 

If necessary, the ports used for the export may need to be opened 
on the PC or server in the network. By default, ports 22 (when 
using the SFTP protocol) and 445 (when using the SMB/CIFS 
protocol) are used.

4) Click Save. 
Related Topics

6.2.6  How to Add a New Language for the User Interface and Report 
Templates 

Prerequisites

• You know the password for configuring the language. 

• The current language texts of the user interface and report templates were 
saved in a CSV file (see How to Export the Language Texts of the User 
Interface and Report Templates ). 

• The texts of the new language are available or known to you. (in case the texts 
of the new language are to be added manually or translated using the Google 
Translator). 

• The CSV file is available to use (in case the texts of the new language are to 
be imported via a CSV file). 

Step by Step

1) Click Start > Program Files > Communication Clients > myReports. You 
will then be presented with the login screen. 

2) Enter Administrator in the Login Name field. 

3) Enter the password for configuring the language in the Password field. If you 
have any questions, please contact the administrator of your communication 
system. 

– If you want to use the SMB (Server Message Block) or CIFS (Common 
Internet File System) protocol, select the item SMB/CIFS in the Protocol 
drop-down list. 

– If you want to use SFTP (Secure File Transfer Protocol), select the item 
SFTP in the Protocol drop-down list. 
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4) Select one of the following options for the Server IP field: 

• If you are using myReports at the OpenScape Office MX communication 
system, enter the IP address of your communication system in the Server 
IP field (if this is not already displayed). 

• If you are using myReports at the HiPath 3000 communication system, 
enter the IP address of the Linux server of OpenScape Office HX in the 
Server IP field (if this is not already displayed). 

5) Click Login. 

6) Click on Administration > Language Setup. A table with the texts of the user 
interface and the report templates in the currently available languages is 
displayed. 

7) Select one of the following options to add the new language for the user 
interface language and for report templates: 

• If you want to import the texts of the new language from a CSV file, 
proceed as follows: 

Click on File > Import from CSV. 

Select the desired new language in the New Language drop-down list 
and click on Browse. Navigate to the storage location of the desired CSV 
file and click OK & Next. The table is then extended by one column, and 
the input fields of the new language are filled with the contents of the CSV 
file.

Click Save. 

Click OK followed by Cancel. 

• If you want to have the texts of the new language translated by Google 
Translator, proceed as follows: 

Select the desired new language in the New Language drop-down list. 

Select the Use Google Translator check box. 

Click the Plus icon. The table is then extended by one column and 
populated with suggested translations from the Google Translator for the 
new language. These suggested translations are based on the standard 
texts of the English user interface and report templates. 

Check the proposed translations and correct or complete them as 
required. 

Click Save. 

Click OK followed by Cancel. 

• If you want to enter the texts of the new language manually, proceed as 
follows:: 

Select the desired new language in the New Language drop-down list. 

Clear the Use GOOGLE Translator check box. 

Click the Plus icon. The table is then extended by one column. 

Enter the texts of the new language in the appropriate fields. 

Click Save. 

Click OK followed by Cancel. 
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8) If you want to use the new language as default language, select the new 
language in the Default Language drop-down list. 

9) Click OK. 

10) Click Close. 
Related Topics

6.2.7  How to Delete a Language for the User Interface and Report Templates 

Prerequisites

• You know the password for configuring the language. 

• The current language texts of all languages for the user interface and report 
templates were saved in a CSV file (see How to Export the Language Texts 
of the User Interface and Report Templates ). 

Step by Step

1) Click Start > Program Files > Communication Clients > myReports. You 
will then be presented with the login screen. 

2) Enter Administrator in the Login Name field. 

3) Enter the password for configuring the language in the Password field. If you 
have any questions, please contact the administrator of your communication 
system. 

4) Select one of the following options for the Server IP field: 

• If you are using myReports at the OpenScape Office MX communication 
system, enter the IP address of your communication system in the Server 
IP field (if this is not already displayed). 

• If you are using myReports at the HiPath 3000 communication system, 
enter the IP address of the Linux server of OpenScape Office HX in the 
Server IP field (if this is not already displayed). 

5) Click Login. 

6) Click on Administration > Language Setup. A table with the texts of the user 
interface and the report templates in the currently available languages is 
displayed. 

7) Select the desired language in the Delete Language drop-down list. 

8) Click on the Trash Can icon, followed by OK. 

9) Click Save. 

10) Click OK followed by Cancel. 

11) Click Close. 
Related Topics
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6.2.8  How to Export the Language Texts of the User Interface and Report 
Templates 

Prerequisites

• You know the password for configuring the language. 

Step by Step

1) Click Start > Program Files > Communication Clients > myReports. You 
will then be presented with the login screen. 

2) Enter Administrator in the Login Name field. 

3) Enter the password for configuring the language in the Password field. If you 
have any questions, please contact the administrator of your communication 
system. 

4) Select one of the following options for the Server IP field: 

• If you are using myReports at the OpenScape Office MX communication 
system, enter the IP address of your communication system in the Server 
IP field (if this is not already displayed). 

• If you are using myReports at the HiPath 3000 communication system, 
enter the IP address of the Linux server of OpenScape Office HX in the 
Server IP field (if this is not already displayed). 

5) Click Login. 

6) Click on Administration > Language Setup. A table with the texts of the user 
interface and the report templates in the currently available languages is 
displayed. 

7) Click on File > Export to CSV. The contents of the CSV file myReports-
Languages.csv are then displayed in the editor. 

8) Save the CSV file in the desired directory and close the file. 

9) Click Close. 
Related Topics
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6.2.9  How to Reset All Languages of the User Interface and Report 
Templates 

Prerequisites

• You know the password for configuring the default language. 

• The current language texts of the user interface and report templates were 
saved in a CSV file (see How to Export the Language Texts of the User 
Interface and Report Templates ). 

Step by Step

1) Click Start > Program Files > Communication Clients > myReports. You 
will then be presented with the login screen. 

2) Enter Administrator in the Login Name field. 

3) Enter the password for configuring the language in the Password field. If you 
have any questions, please contact the administrator of your communication 
system. 

4) Select one of the following options for the Server IP field: 

• If you are using myReports at the OpenScape Office MX communication 
system, enter the IP address of your communication system in the Server 
IP field (if this is not already displayed). 

• If you are using myReports at the HiPath 3000 communication system, 
enter the IP address of the Linux server of OpenScape Office HX in the 
Server IP field (if this is not already displayed). 

5) Click Login. 

6) Click on Administration > Default Language Setup. 

NOTICE:  The Default Language Setup function resets 
(reinitializes) the languages of the user interface and report 
templates. Only the default languages will then be available for 
the user interface and report templates. 

7) Click OK. myReports then performs a reboot. 

Next steps

Log into myReports and add any further languages for the user interface and 
report templates as desired (see How to Add a New Language for the User 
Interface and Report Templates ). 
Related Topics
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7  Appendix

The Appendix provides information on the different user roles and their 
differences and on the database tables available in myReports. 

Related Topics

7.1  myReports User Roles 

myReports has its own user management, which controls access to the functions 
of myReports through user roles. A distinction is made here between the 
myReports users (standard user) and the myReports administrator. 

Your current user role is set when you log into myReports. 

• Logging in as a myReports user: 

– Login Name: This is usually your station number 

– Password: The default password is 1234. 

• Logging in as a myReports administrator: 

– Login Name: The login name is Administrator. 

– Password (Administrator Password): The default password is reports. 

The differences between the roles are summarized in the following table. 

myReports:
Activity

User Role

myReports 
User

myReports 
Administrator

Reports 

Preview report X X

Send report immediately by e-mail X X

Add report template X X

Delete added report template X X

Start Report Designer X

Define new report template X

Update predefined report templates X

Schedules 

Add a schedule X X

Display details of a schedule X X

Edit schedule X X

Delete schedule X X
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Related Topics

Configuration 

Change language of user interface X X

Change color of user interface X X

Configure e-mail template X1 X

Change server address X X

Change administrator password X

Configure e-mail account to send reports 
by e-mail 

X

Configure prefixes for external phone 
numbers 

X

Enable/disable data protection X

Configure the storage location for the 
export of scheduled reports 

X

Add or delete a language X2

Reset languages X2

1 The administrator password must be entered to configure the e-mail template 
2 In order to add or delete a language and reset all languages, you will need to log in as a myReports 

administrator with a special password. 

myReports:
Activity

User Role

myReports 
User

myReports 
Administrator
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7.2  myReports Data Relationship Model

The model shows all database tables and their relationships. 

Related Topics

Related Topics 

• Report Designer
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